XML Injection Affecting python313-FontTools package, versions <4.53.1-160000.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.59% (49th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-PYTHON313FONTTOOLS-15202254
  • published4 Feb 2026
  • disclosed28 Jan 2026

Introduced: 28 Jan 2026

CVE-2025-66034  (opens in a new tab)
CWE-91  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 python313-FontTools to version 4.53.1-160000.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python313-FontTools package and not the python313-FontTools package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

fontTools is a library for manipulating fonts, written in Python. In versions from 4.33.0 to before 4.60.2, the fonttools varLib (or python3 -m fontTools.varLib) script has an arbitrary file write vulnerability that leads to remote code execution when a malicious .designspace file is processed. The vulnerability affects the main() code path of fontTools.varLib, used by the fonttools varLib CLI and any code that invokes fontTools.varLib.main(). This issue has been patched in version 4.60.2.

CVSS Base Scores

version 3.1