Stack-based Buffer Overflow Affecting rrdtool package, versions <1.9.0-160000.4.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.18% (7th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-RRDTOOL-18821590
  • published15 Aug 2026
  • disclosed4 Aug 2026

Introduced: 4 Aug 2026

CVE-2026-43958  (opens in a new tab)
CWE-121  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 rrdtool to version 1.9.0-160000.4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rrdtool package and not the rrdtool package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

A flaw was found in rrdcached, a component of rrdtool. A local attacker with access to a rrdcached socket can exploit a stack-based buffer overflow by sending an oversized CREATE request. This vulnerability can lead to a denial of service by crashing the daemon or potentially allow for arbitrary code execution, impacting the integrity and confidentiality of data.

CVSS Base Scores

version 3.1