Cross-site Request Forgery (CSRF) Affecting sccache package, versions <0.18.0~2-160000.1.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.22% (13th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-SCCACHE-20535961
  • published6 Oct 2026
  • disclosed30 Sept 2026

Introduced: 30 Sep 2026

NewCVE-2024-12224  (opens in a new tab)
CWE-352  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 sccache to version 0.18.0~2-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream sccache package and not the sccache package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

Improper Validation of Unsafe Equivalence in punycode by the idna crate from Servo rust-url allows an attacker to create a punycode hostname that one part of a system might treat as distinct while another part of that system would treat as equivalent to another hostname.

CVSS Base Scores

version 3.1