Integer Overflow or Wraparound Affecting spice-vdagent package, versions <0.22.1-160000.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.11% (2nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-SPICEVDAGENT-18823837
  • published15 Aug 2026
  • disclosed31 Jul 2026

Introduced: 31 Jul 2026

CVE-2026-57965  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 spice-vdagent to version 0.22.1-160000.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream spice-vdagent package and not the spice-vdagent package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

A flaw was found in spice-vdagent. A malicious or compromised SPICE host can trigger an integer overflow by sending a specially crafted message. This vulnerability can lead to a heap buffer overflow, causing the spice-vdagent daemon to crash and resulting in a Denial of Service (DoS) for the virtual machine. This issue requires the SPICE host to be untrusted or compromised for exploitation.

CVSS Base Scores

version 3.1