Heap-based Buffer Overflow Affecting sqlite3-doc package, versions <3.53.2-160000.1.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.36% (30th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-SQLITE3DOC-17439673
  • published24 Jun 2026
  • disclosed18 Jun 2026

Introduced: 18 Jun 2026

CVE-2026-11822  (opens in a new tab)
CWE-122  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 sqlite3-doc to version 3.53.2-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream sqlite3-doc package and not the sqlite3-doc package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

SQLite before 3.53.2 contains memory corruption vulnerabilities in the FTS5 full-text search extension that allow attackers to cause process crashes, memory exhaustion, or arbitrary code execution by supplying a crafted database with malformed FTS5 page data. Attackers can trigger an out-of-bounds read in fts5LeafSeek() via an attacker-controlled loop bound and a heap buffer overflow write in fts5ChunkIterate() through a crafted continuation page causing an integer underflow, exploitable when an FTS5 MATCH query is executed against the malicious database.

CVSS Base Scores

version 3.1