Memory Leak Affecting strongswan package, versions <6.0.6-160000.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.25% (16th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-STRONGSWAN-21363390
  • published21 Oct 2026
  • disclosed8 Oct 2026

Introduced: 8 Oct 2026

NewCVE-2026-78124  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 strongswan to version 6.0.6-160000.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream strongswan package and not the strongswan package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

strongSwan 5.0.2 through 6.0.7 allows PKCS#7 certificate enumeration in the openssl plugin that leads to a lack of release of memory after its effective lifetime.

CVSS Base Scores

version 3.1