Incorrect Authorization Affecting strongswan-nm package, versions <6.0.6-160000.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.45% (39th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-STRONGSWANNM-21363475
  • published21 Oct 2026
  • disclosed8 Oct 2026

Introduced: 8 Oct 2026

NewCVE-2026-78134  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 strongswan-nm to version 6.0.6-160000.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream strongswan-nm package and not the strongswan-nm package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

strongSwan 4.5.0 through 6.0.7 has Incorrect Access Control in the eap-ttls and eap-peap plugins because there can be a missing or mismatched inner EAP identity.

CVSS Base Scores

version 3.1