Inadequate Encryption Strength Affecting github.com/trustwallet/wallet-core package, versions >=2.8.0 <3.1.1


0.0
medium

Snyk CVSS

    Attack Complexity High
    Confidentiality High

    Threat Intelligence

    Exploit Maturity Mature
    EPSS 0.06% (26th percentile)
Expand this section
NVD
5.9 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-SWIFT-TRUSTWALLETWALLETCORE-5489781
  • published 1 May 2023
  • disclosed 1 May 2023
  • credit Unknown

How to fix?

Upgrade trustwallet/wallet-core to version 3.1.1 or higher.

Overview

trustwallet/wallet-core is a mobile-focused library implementing low-level cryptographic wallet functionality for a high number of blockchains

Affected versions of this package are vulnerable to Inadequate Encryption Strength in its mt19937 seed generation, which has only 32 bits of entropy, resulting in only four billion possible mnemonics. Only addresses created via the browser extension are affected, and only between extension versions 0.0.172 and 0.0.182 (i.e. between November 14th and November 23rd, 2022).