Arbitrary Command Injection Affecting 2ndquadrant/pglogical package, versions [,2.3.4)[3.0.0,3.6.26)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.46% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-2NDQUADRANTPGLOGICAL-2365932
  • published26 Jan 2022
  • disclosed1 Jun 2021
  • creditUnknown

Introduced: 1 Jun 2021

CVE-2021-3515  (opens in a new tab)
CWE-77  (opens in a new tab)

How to fix?

Upgrade 2ndquadrant/pglogical to version 2.3.4, 3.6.26 or higher.

Overview

Affected versions of this package are vulnerable to Arbitrary Command Injection. A shell injection flaw was found in pglogical in versions before 2.3.4 and before 3.6.26. An attacker with CREATEDB privileges on a PostgreSQL server can craft a database name that allows execution of shell commands as the postgresql user when calling pglogical.create_subscription().

CVSS Base Scores

version 3.1