Command Injection Affecting aerospike/aerospike-server package, versions [,4.5.3.21)[4.6.0.1,4.6.0.19)[4.7.0.1,4.7.0.17)[4.8.0.1,4.8.0.13)[4.9.0.1,4.9.0.10)[5.0.0.1,5.0.0.7)


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
86.75% (100th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-AEROSPIKEAEROSPIKESERVER-2364334
  • published26 Jan 2022
  • disclosed5 Aug 2020
  • creditUnknown

Introduced: 5 Aug 2020

CVE-2020-13151  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade aerospike/aerospike-server to version 4.5.3.21, 4.6.0.19, 4.7.0.17, 4.8.0.13, 4.9.0.10, 5.0.0.7 or higher.

Overview

Affected versions of this package are vulnerable to Command Injection. Aerospike Community Edition 4.9.0.5 allows for unauthenticated submission and execution of user-defined functions (UDFs), written in Lua, as part of a database query. It attempts to restrict code execution by disabling os.execute() calls, but this is insufficient. Anyone with network access can use a crafted UDF to execute arbitrary OS commands on all nodes of the cluster at the permission level of the user running the Aerospike service.

CVSS Base Scores

version 3.1