Improper Certificate Validation Affecting apache/pulsar-client-cpp package, versions [,2.7.5)[2.8.0,2.8.4)[2.9.0,2.9.3)[2.10.0,2.10.2)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.93% (61st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-APACHEPULSARCLIENTCPP-3104645
  • published4 Nov 2022
  • disclosed4 Nov 2022
  • creditMichael Rowley

Introduced: 4 Nov 2022

CVE-2022-33684  (opens in a new tab)
CWE-295  (opens in a new tab)

How to fix?

Upgrade apache/pulsar-client-cpp to version 2.7.5, 2.8.4, 2.9.3, 2.10.2 or higher.

Overview

Affected versions of this package are vulnerable to Improper Certificate Validation due to not verifying peer TLS certificates when making HTTPS calls for the OAuth2.0 Client Credential Flow, even when tlsAllowInsecureConnection is disabled via configuration. This vulnerability allows an attacker to perform a man-in-the-middle attack and intercept and/or modify the GET request that is sent to the ClientCredentialFlow 'issuer url'. The intercepted credentials can be used to acquire authentication data from the OAuth2.0 server to then authenticate with an Apache Pulsar cluster.An attacker can only take advantage of this vulnerability by taking control of a machine 'between' the client and the server. The attacker must then actively manipulate traffic to perform the attack.

Workaround

Users who are unable to upgrade to the fixed versions should rotate vulnerable OAuth2.0 credentials, including client_id and client_secret.

CVSS Base Scores

version 3.1