Privilege Context Switching Error Affecting apple/cups package, versions [,1.4.4)[1.5-b1,1.5.3)[1.6-b1,1.6.1)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
2.13% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-APPLECUPS-2364827
  • published26 Jan 2022
  • disclosed20 Nov 2012
  • creditUnknown

Introduced: 20 Nov 2012

CVE-2012-5519  (opens in a new tab)
CWE-270  (opens in a new tab)

How to fix?

Upgrade apple/cups to version 1.4.4, 1.5.3, 1.6.1 or higher.

Overview

Affected versions of this package are vulnerable to Privilege Context Switching Error. CUPS 1.4.4, when running in certain Linux distributions such as Debian GNU/Linux, stores the web interface administrator key in /var/run/cups/certs/0 using certain permissions, which allows local users in the lpadmin group to read or write arbitrary files as root by leveraging the web interface.

References

CVSS Base Scores

version 3.1