Remote Code Execution (RCE) Affecting apple/cups package, versions [,1.1.23)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.45% (36th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-APPLECUPS-2364829
  • published26 Jan 2022
  • disclosed10 Jan 2005
  • creditUnknown

Introduced: 10 Jan 2005

CVE-2004-1270  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade apple/cups to version 1.1.23 or higher.

Overview

Affected versions of this package are vulnerable to Remote Code Execution (RCE) lppasswd in CUPS 1.1.22, when run in environments that do not ensure that file descriptors 0, 1, and 2 are open when lppasswd is called, does not verify that the passwd.new file is different from STDERR, which allows local users to control output to passwd.new via certain user input that triggers an error message.

References

CVSS Base Scores

version 3.1