Out-of-bounds Write Affecting aspell package, versions [,0.60.8.1)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.55% (42nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-bounds Write vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-ASPELL-2368341
  • published26 Jan 2022
  • disclosed20 Jul 2021
  • creditUnknown

Introduced: 20 Jul 2021

CVE-2019-25051  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade aspell to version 0.60.8.1 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-bounds Write objstack in GNU Aspell 0.60.8 has a heap-based buffer overflow in acommon::ObjStack::dup_top (called from acommon::StringMap::add and acommon::Config::lookup_list).

CVSS Base Scores

version 3.1