Privilege Escalation Affecting canonical/lightdm package, versions [,0.9.6)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.36% (28th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Privilege Escalation vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-CANONICALLIGHTDM-2368731
  • published26 Jan 2022
  • disclosed19 Nov 2019
  • creditUnknown

Introduced: 19 Nov 2019

CVE-2011-3349  (opens in a new tab)
CWE-269  (opens in a new tab)

How to fix?

Upgrade canonical/lightdm to version 0.9.6 or higher.

Overview

Affected versions of this package are vulnerable to Privilege Escalation lightdm before 0.9.6 writes in .dmrc and Xauthority files using root permissions while the files are in user controlled folders. A local user can overwrite root-owned files via a symlink, which can allow possible privilege escalation.

CVSS Base Scores

version 3.1