Information Exposure Affecting canonical/lightdm package, versions [,1.0.9)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.47% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-CANONICALLIGHTDM-2635963
  • published26 Jan 2022
  • disclosed27 Oct 2014
  • creditUnknown

Introduced: 27 Oct 2014

CVE-2012-1111  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade canonical/lightdm to version 1.0.9 or higher.

Overview

Affected versions of this package are vulnerable to Information Exposure lightdm before 1.0.9 does not properly close file descriptors before opening a child process, which allows local users to write to the lightdm log or have other unspecified impact.

CVSS Base Scores

version 3.1