Code Affecting chrony package, versions [,1.31.1)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
2.94% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-CHRONY-2371512
  • published26 Jan 2022
  • disclosed16 Apr 2015
  • creditUnknown

Introduced: 16 Apr 2015

CVE-2015-1822  (opens in a new tab)
CWE-17  (opens in a new tab)

How to fix?

Upgrade chrony to version 1.31.1 or higher.

Overview

Affected versions of this package are vulnerable to Code chrony before 1.31.1 does not initialize the last "next" pointer when saving unacknowledged replies to command requests, which allows remote authenticated users to cause a denial of service (uninitialized pointer dereference and daemon crash) or possibly execute arbitrary code via a large number of command requests.

CVSS Base Scores

version 3.1