Denial of Service (DoS) Affecting chrony package, versions [,1.31.1)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.7% (75th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-CHRONY-2371515
  • published26 Jan 2022
  • disclosed9 Dec 2019
  • creditUnknown

Introduced: 9 Dec 2019

CVE-2015-1853  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade chrony to version 1.31.1 or higher.

Overview

Affected versions of this package are vulnerable to Denial of Service (DoS) chrony before 1.31.1 does not properly protect state variables in authenticated symmetric NTP associations, which allows remote attackers with knowledge of NTP peering to cause a denial of service (inability to synchronize) via random timestamps in crafted NTP data packets.

CVSS Base Scores

version 3.1