Resource Management Errors Affecting chrony package, versions [,1.23)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
2.7% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-CHRONY-2371517
  • published26 Jan 2022
  • disclosed8 Feb 2010
  • creditUnknown

Introduced: 8 Feb 2010

CVE-2010-0294  (opens in a new tab)
CWE-399  (opens in a new tab)

How to fix?

Upgrade chrony to version 1.23 or higher.

Overview

Affected versions of this package are vulnerable to Resource Management Errors chronyd in Chrony before 1.23.1, and possibly 1.24-pre1, generates a syslog message for each unauthorized cmdmon packet, which allows remote attackers to cause a denial of service (disk consumption) via a large number of invalid packets.

CVSS Base Scores

version 3.1