Remote Code Execution (RCE) Affecting civicrm/civicrm-core package, versions [,4.6.38)


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
2.21% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-CIVICRMCIVICRMCORE-2364187
  • published26 Jan 2022
  • disclosed23 Jul 2018
  • creditUnknown

Introduced: 23 Jul 2018

CVE-2018-1999022  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade civicrm/civicrm-core to version 4.6.38 or higher.

Overview

Affected versions of this package are vulnerable to Remote Code Execution (RCE). PEAR HTML_QuickForm version 3.2.14 contains an eval injection (CWE-95) vulnerability in HTML_QuickForm's getSubmitValue method, HTML_QuickForm's validate method, HTML_QuickForm_hierselect's _setOptions method, HTML_QuickForm_element's _findValue method, HTML_QuickForm_element's _prepareValue method. that can result in Possible information disclosure, possible impact on data integrity and execution of arbitrary code. This attack appear to be exploitable via A specially crafted query string could be utilised, e.g. http://www.example.com/admin/add_practice_type_id[1]=fubar%27])%20OR%20die(%27OOK!%27);%20//&mode=live. This vulnerability appears to have been fixed in 3.2.15.

References

CVSS Base Scores

version 3.1