Race Condition Affecting d-bus package, versions [,1.6.30)[1.8.0,1.8.16)[1.9.0,1.9.10)


Severity

Recommended
0.0
low
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.27% (19th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-DBUS-2371877
  • published26 Jan 2022
  • disclosed13 Feb 2015
  • creditUnknown

Introduced: 13 Feb 2015

CVE-2015-0245  (opens in a new tab)
CWE-362  (opens in a new tab)

How to fix?

Upgrade d-bus to version 1.6.30, 1.8.16, 1.9.10 or higher.

Overview

Affected versions of this package are vulnerable to Race Condition. D-Bus 1.4.x through 1.6.x before 1.6.30, 1.8.x before 1.8.16, and 1.9.x before 1.9.10 does not validate the source of ActivationFailure signals, which allows local users to cause a denial of service (activation failure error returned) by leveraging a race condition involving sending an ActivationFailure signal before systemd responds.

CVSS Base Scores

version 3.1