Cryptographic Issues Affecting dlitz/pycrypto package, versions [,2.6)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
2.37% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Cryptographic Issues vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-DLITZPYCRYPTO-2366739
  • published26 Jan 2022
  • disclosed17 Jun 2012
  • creditUnknown

Introduced: 17 Jun 2012

CVE-2012-2417  (opens in a new tab)
CWE-310  (opens in a new tab)

How to fix?

Upgrade dlitz/pycrypto to version 2.6 or higher.

Overview

Affected versions of this package are vulnerable to Cryptographic Issues. PyCrypto before 2.6 does not produce appropriate prime numbers when using an ElGamal scheme to generate a key, which reduces the signature space or public key space and makes it easier for attackers to conduct brute force attacks to obtain the private key.

CVSS Base Scores

version 3.1