Interpretation Conflict Affecting ethereum/go-ethereum package, versions [1.10.0,1.10.8)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.33% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-ETHEREUMGOETHEREUM-2364925
  • published26 Jan 2022
  • disclosed24 Aug 2021
  • creditUnknown

Introduced: 24 Aug 2021

CVE-2021-39137  (opens in a new tab)
CWE-436  (opens in a new tab)

How to fix?

Upgrade ethereum/go-ethereum to version 1.10.8 or higher.

Overview

Affected versions of this package are vulnerable to Interpretation Conflict go-ethereum is the official Go implementation of the Ethereum protocol. In affected versions a consensus-vulnerability in go-ethereum (Geth) could cause a chain split, where vulnerable versions refuse to accept the canonical chain. Further details about the vulnerability will be disclosed at a later date. A patch is included in the upcoming v1.10.8 release. No workaround are available.

CVSS Base Scores

version 3.1