Access Restriction Bypass Affecting exg/rxvt-unicode package, versions [,9.2)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.36% (28th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-EXGRXVTUNICODE-2366258
  • published26 Jan 2022
  • disclosed7 Apr 2008
  • creditUnknown

Introduced: 7 Apr 2008

CVE-2008-1142  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade exg/rxvt-unicode to version 9.2 or higher.

Overview

Affected versions of this package are vulnerable to Access Restriction Bypass rxvt 2.6.4 opens a terminal window on :0 if the DISPLAY environment variable is not set, which might allow local users to hijack X11 connections. NOTE: it was later reported that rxvt-unicode, mrxvt, aterm, multi-aterm, and wterm are also affected. NOTE: realistic attack scenarios require that the victim enters a command on the wrong machine.

References

CVSS Base Scores

version 3.1