Command Injection Affecting exg/rxvt-unicode package, versions [,9.20)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
4.1% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-EXGRXVTUNICODE-2366259
  • published26 Jan 2022
  • disclosed14 May 2014
  • creditUnknown

Introduced: 14 May 2014

CVE-2014-3121  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade exg/rxvt-unicode to version 9.20 or higher.

Overview

Affected versions of this package are vulnerable to Command Injection rxvt-unicode before 9.20 does not properly handle OSC escape sequences, which allows user-assisted remote attackers to manipulate arbitrary X window properties and execute arbitrary commands.

CVSS Base Scores

version 3.1