Improper Input Validation Affecting gdb package, versions [,8.3)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.11% (65th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-GDB-2317790
  • published14 Dec 2021
  • disclosed21 Jun 2017
  • creditUnknown

Introduced: 21 Jun 2017

CVE-2017-9778  (opens in a new tab)
CWE-20  (opens in a new tab)
CWE-770  (opens in a new tab)

How to fix?

Upgrade gdb to version 8.3 or higher.

Overview

Affected versions of this package are vulnerable to Improper Input Validation. GNU Debugger (GDB) 8.0 and earlier fails to detect a negative length field in a DWARF section. A malformed section in an ELF binary or a core file can cause GDB to repeatedly allocate memory until a process limit is reached. This can, for example, impede efforts to analyze malware with GDB.

CVSS Base Scores

version 3.1