Buffer Overflow Affecting gdb package, versions [0,14.1)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.25% (16th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-GDB-5808317
  • published27 Jul 2023
  • disclosed27 Jul 2023
  • creditUnknown

Introduced: 27 Jul 2023

CVE-2023-39130  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade gdb to version 14.1 or higher.

Overview

Affected versions of this package are vulnerable to Buffer Overflow. GNU gdb (GDB) 13.0.50.20220805-git was discovered to contain a heap buffer overflow via the function pe_as16() at /gdb/coff-pe-read.c.

References

CVSS Base Scores

version 3.1