Out-of-Bounds Affecting gdb package, versions [0,14.1)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.35% (28th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-Bounds vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-GDB-5820005
  • published4 Aug 2023
  • disclosed25 Jul 2023
  • creditUnknown

Introduced: 25 Jul 2023

CVE-2023-39128  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade gdb to version 14.1 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-Bounds. GNU gdb (GDB) 13.0.50.20220805-git was discovered to contain a stack overflow via the ada_decode function at the /gdb/ada-lang.c file.

CVSS Base Scores

version 3.1