Arbitrary Code Execution Affecting gdm package, versions [,2.4.1.6)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.37% (30th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-GDM-2370032
  • published26 Jan 2022
  • disclosed27 Aug 2003
  • creditUnknown

Introduced: 27 Aug 2003

CVE-2003-0547  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade gdm to version 2.4.1.6 or higher.

Overview

Affected versions of this package are vulnerable to Arbitrary Code Execution. GDM before 2.4.1.6, when using the "examine session errors" feature, allows local users to read arbitrary files via a symlink attack on the ~/.xsession-errors file.

References

CVSS Base Scores

version 3.1