Memory Leak Affecting gdraheim/zziplib package, versions [,0.13.70)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.94% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-GDRAHEIMZZIPLIB-2369671
  • published26 Jan 2022
  • disclosed5 Sept 2018
  • creditUnknown

Introduced: 5 Sep 2018

CVE-2018-16548  (opens in a new tab)
CWE-772  (opens in a new tab)

How to fix?

Upgrade gdraheim/zziplib to version 0.13.70 or higher.

Overview

Affected versions of this package are vulnerable to Memory Leak. An issue was discovered in ZZIPlib through 0.13.69. There is a memory leak triggered in the function __zzip_parse_root_directory in zip.c, which will lead to a denial of service attack.

References

CVSS Base Scores

version 3.1