Double Free Affecting gettext package, versions [,0.20.1)


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
4.26% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Double Free vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-GETTEXT-2374263
  • published26 Jan 2022
  • disclosed29 Oct 2018
  • creditUnknown

Introduced: 29 Oct 2018

CVE-2018-18751  (opens in a new tab)
CWE-415  (opens in a new tab)

How to fix?

Upgrade gettext to version 0.20.1 or higher.

Overview

Affected versions of this package are vulnerable to Double Free. An issue was discovered in GNU gettext 0.19.8. There is a double free in default_add_message in read-catalog.c, related to an invalid free in po_gram_parse in po-gram-gen.y, as demonstrated by lt-msgfmt.

CVSS Base Scores

version 3.1