Cryptographic Issues Affecting gnome_online_accounts package, versions [,3.6.3)[3.7.0,3.7.91)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.03% (60th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Cryptographic Issues vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-GNOMEONLINEACCOUNTS-2374426
  • published26 Jan 2022
  • disclosed2 Apr 2013
  • creditUnknown

Introduced: 2 Apr 2013

CVE-2013-1799  (opens in a new tab)
CWE-310  (opens in a new tab)

How to fix?

Upgrade gnome_online_accounts to version 3.6.3, 3.7.91 or higher.

Overview

Affected versions of this package are vulnerable to Cryptographic Issues. Gnome Online Accounts (GOA) 3.6.x before 3.6.3 and 3.7.x before 3.7.91, does not properly validate SSL certificates when creating accounts for providers who use the libsoup library, which allows man-in-the-middle attackers to obtain sensitive information such as credentials by sniffing the network. NOTE: this issue exists because of an incomplete fix for CVE-2013-0240.

References

CVSS Base Scores

version 3.1