Arbitrary Command Injection Affecting gparted package, versions [,0.15.0)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
1.11% (62nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-GPARTED-2381877
  • published26 Jan 2022
  • disclosed19 Dec 2014
  • creditUnknown

Introduced: 19 Dec 2014

CVE-2014-7208  (opens in a new tab)
CWE-77  (opens in a new tab)

How to fix?

Upgrade gparted to version 0.15.0 or higher.

Overview

Affected versions of this package are vulnerable to Arbitrary Command Injection. GParted before 0.15.0 allows local users to execute arbitrary commands with root privileges via shell metacharacters in a crafted filesystem label.

CVSS Base Scores

version 3.1