Range Error Affecting gtk-vnc package, versions [,0.7.0)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
2.32% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-GTKVNC-2381890
  • published26 Jan 2022
  • disclosed28 Feb 2017
  • creditUnknown

Introduced: 28 Feb 2017

CVE-2017-5884  (opens in a new tab)
CWE-118  (opens in a new tab)

How to fix?

Upgrade gtk-vnc to version 0.7.0 or higher.

Overview

Affected versions of this package are vulnerable to Range Error gtk-vnc before 0.7.0 does not properly check boundaries of subrectangle-containing tiles, which allows remote servers to execute arbitrary code via the src x, y coordinates in a crafted (1) rre, (2) hextile, or (3) copyrect tile.

References

CVSS Base Scores

version 3.1