Out-of-Bounds Affecting irssi/irssi package, versions [,1.0.3)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
6.08% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-Bounds vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-IRSSIIRSSI-2366209
  • published26 Jan 2022
  • disclosed7 Jun 2017
  • creditUnknown

Introduced: 7 Jun 2017

CVE-2017-9469  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade irssi/irssi to version 1.0.3 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-Bounds. In Irssi before 1.0.3, when receiving certain incorrectly quoted DCC files, it tries to find the terminating quote one byte before the allocated memory. Thus, remote attackers might be able to cause a crash.

References

CVSS Base Scores

version 3.1