Use of Externally-Controlled Format String Affecting irssi/irssi package, versions [,1.0.6)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.91% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Use of Externally-Controlled Format String vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-IRSSIIRSSI-2366210
  • published26 Jan 2022
  • disclosed6 Jan 2018
  • creditUnknown

Introduced: 6 Jan 2018

CVE-2018-5207  (opens in a new tab)
CWE-134  (opens in a new tab)

How to fix?

Upgrade irssi/irssi to version 1.0.6 or higher.

Overview

Affected versions of this package are vulnerable to Use of Externally-Controlled Format String. When using an incomplete variable argument, Irssi before 1.0.6 may access data beyond the end of the string.

References

CVSS Base Scores

version 3.1