Out-of-bounds Read Affecting irssi/irssi package, versions [,1.0.5)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.99% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-bounds Read vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-IRSSIIRSSI-2366217
  • published26 Jan 2022
  • disclosed22 Oct 2017
  • creditUnknown

Introduced: 22 Oct 2017

CVE-2017-15722  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade irssi/irssi to version 1.0.5 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-bounds Read. In certain cases, Irssi before 1.0.5 may fail to verify that a Safe channel ID is long enough, causing reads beyond the end of the string.

References

CVSS Base Scores

version 3.1