Out-of-bounds Read Affecting irssi/irssi package, versions [,0.8.21)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
4.78% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-bounds Read vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-IRSSIIRSSI-2366219
  • published26 Jan 2022
  • disclosed3 Mar 2017
  • creditUnknown

Introduced: 3 Mar 2017

CVE-2017-5356  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade irssi/irssi to version 0.8.21 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-bounds Read. Irssi before 0.8.21 allows remote attackers to cause a denial of service (out-of-bounds read and crash) via a string containing a formatting sequence (%[) without a closing bracket (]).

References

CVSS Base Scores

version 3.1