Denial of Service (DoS) Affecting irssi/irssi package, versions [,0.8.16)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
2.88% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-IRSSIIRSSI-2366223
  • published26 Jan 2022
  • disclosed16 Apr 2010
  • creditUnknown

Introduced: 16 Apr 2010

CVE-2010-1156  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade irssi/irssi to version 0.8.16 or higher.

Overview

Affected versions of this package are vulnerable to Denial of Service (DoS) core/nicklist.c in Irssi before 0.8.15 allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via vectors related to an attempted fuzzy nick match at the instant that a victim leaves a channel.

References

CVSS Base Scores

version 3.1