Out-of-Bounds Affecting irssi/irssi package, versions [,1.0.6)


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
2.38% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-Bounds vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-IRSSIIRSSI-2366225
  • published26 Jan 2022
  • disclosed6 Jan 2018
  • creditUnknown

Introduced: 6 Jan 2018

CVE-2018-5208  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade irssi/irssi to version 1.0.6 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-Bounds. In Irssi before 1.0.6, a calculation error in the completion code could cause a heap buffer overflow when completing certain strings.

References

CVSS Base Scores

version 3.1