Improper Input Validation Affecting irssi/irssi package, versions [,0.8.16)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.56% (72nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-IRSSIIRSSI-2366231
  • published26 Jan 2022
  • disclosed16 Apr 2010
  • creditUnknown

Introduced: 16 Apr 2010

CVE-2010-1155  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade irssi/irssi to version 0.8.16 or higher.

Overview

Affected versions of this package are vulnerable to Improper Input Validation. Irssi before 0.8.15, when SSL is used, does not verify that the server hostname matches a domain name in the subject's Common Name (CN) field or a Subject Alternative Name field of the X.509 certificate, which allows man-in-the-middle attackers to spoof IRC servers via an arbitrary certificate.

CVSS Base Scores

version 3.1