Command Injection Affecting kde/kconfig package, versions [,5.61.0)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
4.07% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-KDEKCONFIG-2365245
  • published26 Jan 2022
  • disclosed7 Aug 2019
  • creditUnknown

Introduced: 7 Aug 2019

CVE-2019-14744  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade kde/kconfig to version 5.61.0 or higher.

Overview

Affected versions of this package are vulnerable to Command Injection. In KDE Frameworks KConfig before 5.61.0, malicious desktop files and configuration files lead to code execution with minimal user interaction. This relates to libKF5ConfigCore.so, and the mishandling of .desktop and .directory files, as demonstrated by a shell command on an Icon line in a .desktop file.

CVSS Base Scores

version 3.1