Information Exposure Affecting kde/plasma-desktop package, versions [,5.1.1)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.44% (70th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-KDEPLASMADESKTOP-2365561
  • published26 Jan 2022
  • disclosed26 Jan 2015
  • creditUnknown

Introduced: 26 Jan 2015

CVE-2015-1308  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade kde/plasma-desktop to version 5.1.1 or higher.

Overview

Affected versions of this package are vulnerable to Information Exposure kde-workspace 4.2.0 and plasma-workspace before 5.1.95 allows remote attackers to obtain input events, and consequently obtain passwords, by leveraging access to the X server when the screen is locked.

CVSS Base Scores

version 3.1