Out-of-bounds Write Affecting leptonica package, versions [,1.75.3)


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
3.4% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-bounds Write vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-LEPTONICA-2370259
  • published26 Jan 2022
  • disclosed16 Feb 2018
  • creditUnknown

Introduced: 16 Feb 2018

CVE-2018-7186  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade leptonica to version 1.75.3 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-bounds Write. Leptonica before 1.75.3 does not limit the number of characters in a %s format argument to fscanf or sscanf, which allows remote attackers to cause a denial of service (stack-based buffer overflow) or possibly have unspecified other impact via a long string, as demonstrated by the gplotRead and ptaReadStream functions.

References

CVSS Base Scores

version 3.1