NULL Pointer Dereference Affecting libextractor package, versions [,1.7)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
2.36% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about NULL Pointer Dereference vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-LIBEXTRACTOR-2374247
  • published26 Jan 2022
  • disclosed6 Dec 2017
  • creditUnknown

Introduced: 6 Dec 2017

CVE-2017-17440  (opens in a new tab)
CWE-476  (opens in a new tab)

How to fix?

Upgrade libextractor to version 1.7 or higher.

Overview

Affected versions of this package are vulnerable to NULL Pointer Dereference. GNU Libextractor 1.6 allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via a crafted GIF, IT (Impulse Tracker), NSFE, S3M (Scream Tracker 3), SID, or XM (eXtended Module) file, as demonstrated by the EXTRACTOR_xm_extract_method function in plugins/xm_extractor.c.

CVSS Base Scores

version 3.1