Out-of-Bounds Affecting libextractor package, versions [,1.6)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.51% (74th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-Bounds vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-LIBEXTRACTOR-2374250
  • published26 Jan 2022
  • disclosed18 Oct 2017
  • creditUnknown

Introduced: 18 Oct 2017

CVE-2017-15602  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade libextractor to version 1.6 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-Bounds. In GNU Libextractor 1.4, there is an integer signedness error for the chunk size in the EXTRACTOR_nsfe_extract_method function in plugins/nsfe_extractor.c, leading to an infinite loop for a crafted size.

References

CVSS Base Scores

version 3.1