Out-of-bounds Write Affecting libextractor package, versions [,1.7)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
2.11% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-bounds Write vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-LIBEXTRACTOR-2374252
  • published26 Jan 2022
  • disclosed17 Jul 2018
  • creditUnknown

Introduced: 17 Jul 2018

CVE-2018-14346  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade libextractor to version 1.7 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-bounds Write. GNU Libextractor before 1.7 has a stack-based buffer overflow in ec_read_file_func (unzip.c).

References

CVSS Base Scores

version 3.1