Out-of-bounds Read Affecting libidn package, versions [0,1.33)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
6.72% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-bounds Read vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-LIBIDN-2368567
  • published26 Jan 2022
  • disclosed7 Sept 2016
  • creditUnknown

Introduced: 7 Sep 2016

CVE-2015-8948  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade libidn to version 1.33 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-bounds Read idn in GNU libidn before 1.33 might allow remote attackers to obtain sensitive memory information by reading a zero byte as input, which triggers an out-of-bounds read.

References

CVSS Base Scores

version 3.1