Out-of-bounds Write Affecting libiec61850 package, versions [0,1.3.1)


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
2.12% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-bounds Write vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-LIBIEC61850-2369363
  • published26 Jan 2022
  • disclosed12 Nov 2018
  • creditUnknown

Introduced: 12 Nov 2018

CVE-2018-19185  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade libiec61850 to version 1.3.1 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-bounds Write. An issue has been found in libIEC61850 v1.3. It is a heap-based buffer overflow in BerEncoder_encodeOctetString in mms/asn1/ber_encoder.c. This is exploitable even after CVE-2018-18834 has been patched, with a different dataSetValue sequence than the CVE-2018-18834 attack vector.

CVSS Base Scores

version 3.1