Out-of-bounds Read Affecting libntlm package, versions [0,1.6)


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
3.11% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-bounds Read vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-LIBNTLM-2379526
  • published26 Jan 2022
  • disclosed10 Oct 2019
  • creditUnknown

Introduced: 10 Oct 2019

CVE-2019-17455  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade libntlm to version 1.6 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-bounds Read. Libntlm through 1.5 relies on a fixed buffer size for tSmbNtlmAuthRequest, tSmbNtlmAuthChallenge, and tSmbNtlmAuthResponse read and write operations, as demonstrated by a stack-based buffer over-read in buildSmbNtlmAuthRequest in smbutil.c for a crafted NTLM request.

References

CVSS Base Scores

version 3.1